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1. 简介
MPLAB 分析工具套件是分析工具的集合，可集成在 MPLAB X IDE 中，支持所有 Microchip MCU、MPU、CEC 和

DSC 器件。该套件可在 IDE 中执行 MPLAB 代码覆盖功能和 MISRA®（汽车工业软件可靠性联合会）检查功能。

凭借 MPLAB 代码覆盖功能，可查看执行了代码的哪些部分。IDE 中的 MISRA 检查功能提供了相关准则，可确保嵌入

式系统中 C 代码的安全性、保密性、可移植性和可靠性。

1.1 许可证
可通过 Microchip 直销网站购买 MPLAB 分析工具套件的许可证，具体如下：

• MPLAB 分析工具工作站许可证

部件编号：SW006027-2 www.microchip.com/en-us/development-tool/SW006027-2
• MPLAB 分析工具高优先级访问（High Priority Access，HPA）工作站许可证

部件编号：SW006027-2H www.microchip.com/en-us/development-tool/SW006027-2H
• MPLAB 分析工具网络服务器许可证

部件编号：SW006027-2N www.microchip.com/en-us/development-tool/SW006027-2N
• MPLAB 分析工具 HPA 网络服务器许可证

部件编号：SW006027-2NH www.microchip.com/en-us/development-tool/SW006027-2NH

可通过 Microchip 直销网站购买许可证。
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2. MPLAB 代码覆盖

2.1 MPLAB 代码覆盖概述
凭借 MPLAB 分析工具套件中的 MPLAB 代码覆盖功能，可查看执行了代码的哪些部分。测试用例运行完毕后可直观显

示代码覆盖数据。请参见[AoU-09-COV]。

使用 MPLAB 代码覆盖功能时需要以下工具：

• 支持代码覆盖输出的免费版或专业版 MPLAB XC C 编译器（MPLAB XC8 v2.35/MPLAB XC16 v2.0/MPLAB
XC32 v4.0 及更高版本）。请参见[AoU-02-COV]。

• MPLAB 分析工具套件许可证（见 1.1.  许可证，包含代码覆盖功能），拥有它才有权查看执行了代码的哪些部

分。请参见[AoU-05-COV]。
• MPLAB X IDE v6.0 或更高版本，它支持搭配使用 MPLAB XC C 编译器和 MPLAB 分析工具套件许可证来显示代

码覆盖数据。请参见[AoU-04-COV]。

注： 本手册是针对 MPLAB X IDE v6.0 或更高版本编写的。

注： 使用 MPLAB X IDE 可获得最佳代码覆盖体验。

MPLAB X IDE 中会在以下几个部分显示代码覆盖数据：

• 编辑器文本，用代表不同覆盖的颜色突出显示：绿色 = 已执行，黄色 = 已部分执行，红色 = 未执行。

• Program Memory（程序存储器），用代表不同覆盖的颜色突出显示。

• Code Coverage（代码覆盖）选项卡，以报告形式用彩色显示所覆盖代码的百分比。此信息可写入 HTML 报告，

供以后查看。
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图 2-1. 代码覆盖——编辑器窗口和 Code Coverage 选项卡

图 2-2. 代码覆盖——Program Memory 窗口
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2.2 在安全环境中使用 MPLAB 代码覆盖

注意： 要在安全环境中使用 MPLAB 分析工具套件，必须使用 Microchip 功能安全版编译器。目前尚未提供

支持 MPLAB 分析工具套件的新版功能安全编译器。有关相应的功能安全编译器许可证，请访问
www.microchip.com/en-us/solutions/functional-safety/mplab-development-ecosystem-for-functional-
safety：
• MPLAB XC8 功能安全许可证（支持 MPLAB 分析工具套件）

• MPLAB XC16 功能安全许可证（支持 MPLAB 分析工具套件）

• MPLAB XC32 功能安全许可证（支持 MPLAB 分析工具套件）

MPLAB 代码覆盖根据 Microchip 开发工具标准流程进行设计。Microchip 声明特定的使用假设（Assumption of Use，
AoU）来满足系统级的技术和功能安全要求。下文对 AoU 进行了介绍。其中一些 AoU 可参见本手册的其他章节，这些

AoU 作为所讨论特定主题的一部分进行了介绍。

系统集成商负责满足本手册中列出的所有 AoU，并确保每个元件或产品均已遵循列出的 AoU，以便能够通过 MPLAB
代码覆盖分析应用程序。

系统集成商有两个选择：

• 确保满足每条假设

• 忽略假设

在第一种情况下，系统集成商必须证明已满足每条假设；在第二种情况下，系统集成商必须详细说明为何忽略假设不

会违反安全要求，或者详细说明如何采用其他方式充分满足假设的。

根据 Microchip 功能安全版编译器随附的分类文档所述，MPLAB 代码覆盖工具属于 TCL 1 类。该分类基于使用假设和

FMEA 中提供的用例。

表 2-1. 责任程度

必须 必须遵守

应 建议

使用假设 说明

[AoU-01-COV] 工具用户必须提供确证的数据源或方法。

[AoU-02-COV] MPLAB 代码覆盖工具只能与受支持的功能安全版 MPLAB XC 编译器配合使用。

[AoU-03-COV] 代码覆盖必须与真实功能安全流程配合使用。

[AoU-04-COV] 代码覆盖必须与适当版本的 MPLAB X IDE 配合使用。

[AoU-05-COV] 代码覆盖用户必须具备有效的许可证。

[AoU-06-COV] 代码覆盖只能在开发和调试应用程序时使用，不得在最终用户运行应用程序时使用。

[AoU-07-COV] 代码覆盖必须在受控的安全测试环境下使用。

[AoU-08-COV] 代码覆盖只能用于受支持的 Microchip 单片机和 DSC。

[AoU-09-COV] 在检查和分析代码覆盖数据之前，必须确保测试已运行完毕且应用程序处于静止状态。

2.3 MPLAB 代码覆盖详细信息
MPLAB 代码覆盖许可证与支持代码覆盖的 MPLAB XC C 编译器和 MPLAB X IDE 版本搭配使用来查看代码覆盖输

出。请参见[AoU-02-COV]、[AoU-04-COV]和[AoU-05-COV]。
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MPLAB 代码覆盖支持任何从 C 源代码编译的内容。可执行映像中不存在非彩色的 C 源代码。此类代码不计为覆盖或

未覆盖。例如，常见的“while(TRUE)”语句绝对不会生成可执行的指令。

MPLAB X IDE 所支持的任何调试工具同样也都支持 MPLAB 代码覆盖。

编译器操作

代码覆盖由 MPLAB XC C 编译器插装提供支持。编译器通过在程序存储器中添加极少量的代码来在 RAM 中更新标志

以指示代码覆盖。要在开发结束时从应用程序中删除此代码，应按照 2.5.  使能/禁止代码覆盖禁止代码覆盖并运行应用

程序。这样便可确保从现场运行的产品中删除代码。请参见[AoU-04-COV]。

注： 代码覆盖仅适用于 ELF 文件。

MPLAB X IDE 操作

IDE 将突出显示项目中文件的已覆盖代码及其百分比。您可以通过设置文件属性来选择查看哪些文件的代码覆盖数据。

请参见 2.7.2.3.  针对项目中文件的代码覆盖。

此外，还可以生成覆盖报告。请参见 2.8.  创建代码覆盖 HTML 报告。

2.4 获取软件
要使用代码覆盖，您将需要获取以下工具。

MPLAB X IDE

自 MPLAB X IDE v5.25 起，支持查看代码覆盖输出。此外，v5.30 中还增加了其他功能。但在 MPLAB X IDE v6.0
中，代码覆盖与 MISRA 检查在 MPLAB 分析工具套件许可证中捆绑在一起。请参见[AoU-04-COV 和 AoU-05-COV]。

可以从 www.microchip.com/mplab/mplab-x-ide 免费下载 IDE。

MPLAB XC C 编译器

MPLAB 分析工具套件许可证可与任何支持代码覆盖的免费版和专业版 MPLAB XC C 编译器搭配使用。请参见

[AoU-02-COV]。

支持代码覆盖的最低版本如下：

• MPLAB XC8 v2.35
• MPLAB XC16 v2.0
• MPLAB XC32 v4.0

可从 www.microchip.com/mplab/compilers 下载 MPLAB XC C 编译器。

MPLAB 分析工具套件许可证

可以按照与其他编译器许可证相同的方法购买并激活 MPLAB 分析工具套件许可证。更多信息，请参见《安装

MPLAB® XC C 编译器并获取许可证》（DS50002059J_CN）。请参见[AoU-05-COV]。有关许可证部件编号，请参见

1.1.  许可证。

该许可证对于计算机上的所有 MPLAB XC C 编译器均适用。该许可证可与免费版和专业版编译器搭配使用。

2.5 使能/禁止代码覆盖
默认情况下，MPLAB 代码覆盖处于禁止状态。要使能代码覆盖，请按照以下步骤操作：

打开 Project Properties（项目属性）对话框，选择 Tools > Analysis > Code Coverage（工具 > 分析 > 代码覆盖），

或者也可在 Projects（项目）窗口中右键单击项目名称，然后选择“Properties”（属性）。

1. 单击 Categories（类别）下的“Analysis”（分析）。

2. 在 Option categories (General)（选项类别（通用））下，针对“Code Coverage Instrumentation”（代码覆盖

插装）做出选择。不同 MPLAB XC 编译器的选择也会有所不同（见下表）。
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表 2-2. 编译器的代码覆盖使能选项

MPLAB® XC C
编译器

使能选项 说明

XC8 Disable（禁止） 禁止代码覆盖。

Enable（使能） 使能代码覆盖。

XC16 Disable 禁止代码覆盖。

Enable Near memory（使能

Near 存储区）

使用 Near RAM 空间进行代码覆盖插装（推荐）。如果存在链接

错误，请选择 Far。

Enable Far memory（使能

Far 存储区）

使用 Far RAM 空间进行代码覆盖插装。

XC32 Disable 禁止代码覆盖。

Enable 使能代码覆盖。

图 2-3. 代码覆盖选项——MPLAB® XC16 示例

2.6 查看代码覆盖输出
按 2.5.  使能/禁止代码覆盖中所述使能代码覆盖后，请调试代码并执行完所有测试用例。随后，自动或手动停止执行并

根据需要单步执行，直到执行完所有代码为止。

要查看代码覆盖，请按以下步骤操作：

• 右键单击项目名称并选择“Show Code Coverage Summary”（显示代码覆盖汇总），或者选择 Window >
Debugging > Code Coverage（窗口 > 调试 > 代码覆盖）。

• 要在编辑器窗口中进行突出显示，可能需要在其中单击。覆盖的代码随后将在窗口中突出显示。
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• 要在 Program Memory（或 Execution Memory（执行存储器））窗口中突出显示，应在 Windows > Target
Memory Views（窗口 > 目标存储器视图）下将其打开。随后将在窗口中突出显示覆盖的指令。

• 汇总报告将显示在 Code Coverage 选项卡中。

图 2-4. MPLAB® X IDE 中的代码覆盖

2.6.1 突出显示颜色

下表对编辑器窗口以及 Program Memory 或 Execution Memory 窗口中突出显示颜色的含义进行了说明。

突出显示颜色 突出显示名称 含义

绿色 已覆盖并已执行

黄色 已覆盖并部分执行（仅编辑器窗口）

红色 已覆盖但未执行

无颜色 未生成覆盖信息 1

注 1：无法生成覆盖信息的原因包括：

• 某些 C 结构可能导致 C 源代码行不会生成代码

• 优化可能导致 C 源代码行不会生成代码

其他情况也可能导致 C 源代码行不会生成可执行代码，相关示例请参见 2.7.  了解代码覆盖输出。
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2.6.2 覆盖颜色
在 Code Coverage 选项卡上，“Coverage”（覆盖）下方条形图上的颜色具有以下含义：

覆盖颜色 覆盖名称 含义

绿色 测试套件已覆盖并执行全部代码。

红色 测试套件已覆盖全部代码。

有关该选项卡的更多信息，请参见 2.7.1.2.  Code Coverage 窗口。

2.6.3 Code Coverage 选项卡按钮

单击该选项卡左侧装订线中的按钮可实现以下功能。

生成 HTML 报告。该报告将显示与 Code Coverage 窗口中相同的数据。

在编辑器窗口中翻转（使能/禁止）颜色突出显示。

打开 Project Properties（项目属性）窗口以使能/禁止代码覆盖。

2.7 了解代码覆盖输出
以下各节详细介绍了不同 IDE 显示画面中所显示的代码覆盖内容。

2.7.1 演示代码示例

图 2-5. 编辑器窗口——演示代码示例
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此处使用了用于 PIC24FJ128GA010 PIM 的 Explorer 16/32 板演示代码，可从以下位置获取：

www.microchip.com/DM240001-2

2.7.1.1 演示代码和覆盖颜色

对于上图所示的 case '\n'语句：

• 两个 if语句条件均已执行，因此显示为绿色（已覆盖并已执行）。

• 两个 if语句的结果均为假，因此后面的函数显示为红色（已覆盖但未执行）。

• 第二个 if语句的 else满足，因此后面的函数得以执行并显示为绿色。

• case语句的 break显示为黄色，即部分覆盖（已覆盖但部分执行），这似乎与预期不符，因为两个 if语句均

已执行。要想了解部分覆盖的原因，需要查看 Program Memory 窗口。

图 2-6. Program Memory——演示代码示例

要查看视图（如上图所示），请按照以下步骤操作：
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• 暂停程序执行。

• 打开 Program Memory 窗口：Window > Target Memory Views > Program Memory（窗口 > 目标存储器视图 > 程
序存储器）。

• 在编辑器窗口中的 case '\n'的第二条 if语句处放置一个断点。

• 调试，直到程序在断点处暂停。

• 单步执行一次。

在 Program Memory 窗口中，可以看到 else子句和 break语句的指令。编译器已将从函数调用返回以及跳出 case
循环组合到一个跳转中，此操作将 break语句与循环相关联。因此，它将显示为黄色，这是因为条件为真的 if语句

从未执行。

查看 Program Memory 窗口可帮助您了解某些行被部分覆盖（黄色）的原因。通常，可以通过编写测试来删除红色的

行（已覆盖但未执行），从而最大程度地减少部分覆盖的行。随后可以在 Program Memory 窗口中检查汇编代码中剩

余的黄色行。

2.7.1.2 Code Coverage 窗口

要打开 Code Coverage 窗口，请选择 Windows > Debugging > Code Coverage（窗口 > 调试 > 代码覆盖）。该窗口

将显示测试代码对应用程序代码的覆盖程度。

暂停程序执行后，将显示应用程序中每个文件的当前覆盖百分比。单击箭头可查看文件中各函数的细分覆盖数据。

覆盖以地址单元表示，其中地址单元表示项目器件架构执行部分可寻址的存储器的原子单元。

覆盖百分比（绿色）即 x/(x+y)，其中 x = 已覆盖的地址单元，y = 未覆盖的地址单元。

图 2-7. Code Coverage 窗口
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2.7.2 简单代码示例

图 2-8. 编辑器窗口——简单代码示例

使用简单 C 代码结构来演示代码覆盖。

2.7.2.1 简单代码和覆盖颜色

无颜色——无覆盖数据

某些 C 结构不会生成可执行代码，因此没有突出显示。上图所示的示例包括：

• 预处理器声明——#include语句

• 变量声明和初始化

• 注释或注释掉的代码

绿色——已覆盖并已执行

当完全执行某行上的代码时，该行完全覆盖。

main()函数完全执行并返回，因此开始、返回和结束行呈现为完全覆盖。
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for循环的各行全部执行完毕，但 break语句除外，这是因为从未满足 if条件。在循环和条件语句中，存在一个或

多个必须进行完全覆盖测试的条件或分支。

在某行上调用并执行完的函数（例如 calcAdd()）将视为完全覆盖。

黄色——部分覆盖

当某行上的代码已覆盖但仅部分执行时，将视为部分覆盖。

对于简单的 if语句，已执行 a<b的求值，但未执行 j=1赋值。因此，该行被部分覆盖。如果语句在不同的行上，您

将看到：

if-else语句使用二进制逻辑来确定分支条件。由于选择的变量值，该语句仅被部分覆盖，这是因为 a具有非零值，

而 b不会进行求值。

红色——已覆盖但未执行

如上文所述，在循环和条件语句中，存在一个或多个必须进行完全覆盖测试的条件或分支。

for循环中的 if语句始终不为真，因此不会执行后面的 break语句。

已求值 if-else语句的条件，因此始终不会选择 else分支，从而不会执行其后包含 calcSub()的行。

2.7.2.2 编辑器中的覆盖限制

编辑器窗口将显示多行 C 代码。C 是一种高级语言，根据器件的不同，一行 C 代码可以表示一条或多条机器指令。因

此，可能有必要在 Program Memory（或 Execution Memory）窗口中查看实际的机器指令，以确定导致所示覆盖的原

因。

以代码中注释掉的 while(1)循环为例。如果去掉注释，再次运行程序然后暂停，则 Output（输出）窗口中可能显示

以下文本：

No source code lines were found at current PC 0x330.Open program memory view to see 
instruction code disassembly.

要打开 Program Memory（8 位或 16 位器件）窗口，请选择 Windows > Target Memory Views > Program Memory
（窗口 > 目标存储器视图 > 程序存储器）。要打开 Execution Memory（32 位器件）窗口，请选择 Windows > Target
Memory Views > Execution Memory（窗口 > 目标存储器视图 > 执行存储器）。
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图 2-9. Program Memory——简单代码示例

地址 0x330处是一条分支指令；因此编译器生成了 while(1)的这种表示。这不会被视为源代码，因此会生成上面所

示的输出文本。

2.7.2.3 针对项目中文件的代码覆盖

对于简单代码示例，根据编辑器窗口中的覆盖数据，可轻松得到 Code Coverage 窗口的百分比。对于较复杂的应用程

序（例如演示代码），按文件和函数对覆盖进行细分可提供有用的信息来改善测试和覆盖。

图 2-10. Code Coverage 窗口——简单代码示例

要为项目中的特定文件提供目标代码覆盖，可以更改文件编译属性。

1. 右键单击项目中的文件，然后从下拉菜单中选择“Properties”。“File Properties”（文件属性）对话框随后

将打开。
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2. 在此对话框中，选中“Override build options”（覆盖编译选项）。此时将出现编译选项的其他选择。单击

“Code Coverage”。
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3. 将“Code Coverage instrumentation”选项更改为“Disable”（禁止），然后单击 OK（确定）。
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4. 此时，文件将在项目中以粗体显示。运行并暂停项目，然后检查 Code Coverage 窗口。该文件将不再在此处列

出。在编辑器中打开文件，可发现没有突出显示代码覆盖情况。

2.8 创建代码覆盖 HTML 报告

可通过单击 Code Coverage 选项卡上的 Generate HTML Report（生成 HTML 报告）按钮 将代码覆盖信息保存

到文件中。

有关覆盖颜色含义的信息，请参见 2.6.1.  突出显示颜色。
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图 2-11. 源文件列表和覆盖
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图 2-12. 源文件列表和覆盖详细信息

2.9 通过 MDB 实现针对代码覆盖的命令行支持
已使用 MDB 为命令行工具添加了对 MPLAB 代码覆盖的支持。要在 MDB 中生成代码覆盖报告，请按以下步骤操作：

• 通过使能代码覆盖属性生成 ELF 文件。请参见 2.5.  使能/禁止代码覆盖。

• 选择报告类型（html、gcov和 all）——请参见下表。

• 提供 html报告路径（默认：项目位置）——请参见下表。

• 如果报告已存在，将 replacehtmlreport设置为 true——请参见下表。

• 如果使用 MDB 调用以下示例，将生成 HTML 报告。
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示例

Device PIC16F886
set xccodecoverage.reporttype html
set xccodecoverage.htmlreportpath d:\report
set xccodecoverage.replacehtmlreport true
Hwtool SIM
Program "d:\testCoverage.elf"
Break main.c:41
Run
Wait 2000
Quit

有关命令选项的更多信息，请参见《Microchip 调试器（MDB）用户指南》（DS50002102E_CN）。在线帮助位于

onlinedocs.microchip.com/，可在其中搜索“Microchip Debugger”。MDB 用户指南 PDF 位于 MPLAB X IDE 网页

www.microchip.com/en-us/development-tools-tools-and-software/mplab-x-ide 上的 Documentation（文档）选项卡

下。
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3. MISRA 检查

3.1 MISRA 检查概述
MPLAB 分析工具套件中的 MPLAB MISRA 检查功能是由汽车工业软件可靠性联合会（Motor Industry Software
Reliability Association，MISRA）制定的一组 C 编码标准。MISRA 准则有助于确保嵌入式系统中 C 代码的安全性、保

密性、可移植性和可靠性。

通过从 MPLAB X IDE Tools（工具）菜单执行“MISRA Check”（MISRA 检查），可按照一组 MISRA 规则进行静态

代码分析。在 MPLAB X IDE 中，使用 MISRA C:2012 规则。

MISRA 检查功能是 MPLAB X IDE v6.0 或更高版本中捆绑的一个分析工具。请参见[AoU-04-MISRA]。

MPLAB 分析工具套件许可证包含 MISRA 检查（见 1.1.  许可证）。请参见[AoU-08-MISRA]。

3.2 在安全环境中使用 MISRA 检查

注意： 要在安全环境中使用 MPLAB 分析工具套件，必须使用 Microchip 功能安全版编译器。目前尚未提供

支持 MPLAB 分析工具套件的新版功能安全编译器。有关相应的功能安全编译器许可证，请访问
www.microchip.com/en-us/solutions/functional-safety/mplab-development-ecosystem-for-functional-
safety：
• MPLAB XC8 功能安全许可证（支持 MPLAB 分析工具套件）

• MPLAB XC16 功能安全许可证（支持 MPLAB 分析工具套件）

• MPLAB XC32 功能安全许可证（支持 MPLAB 分析工具套件）

MISRA 检查根据 Microchip 开发工具标准流程进行设计。Microchip 声明特定的使用假设（Assumptions of Use，
AoU）来满足系统级的技术和功能安全要求。下文对 AoU 进行了介绍。其中一些 AoU 可参见本手册的其他章节，这些

AoU 作为所讨论特定主题的一部分进行了介绍。

系统集成商负责满足本手册中列出的所有 AoU，并确保每个元件或产品均已遵循列出的 AoU，以便能够通过 MISRA
检查分析应用程序。

系统集成商有两个选择：

• 确保满足每条假设

• 忽略假设

在第一种情况下，系统集成商必须证明已满足每条假设；在第二种情况下，系统集成商必须详细说明为何忽略假设不

会违反安全要求，或者详细说明如何采用其他方式充分满足假设的。

根据 Microchip 功能安全版编译器随附的分类文档所述，MISRA 检查（务必十分仔细，不可粗略估计）属于 TCL 1
类。该分类基于使用假设和分类文档中提供的用例。

注： MISRA 检查根据 Microchip 开发工具标准流程进行设计。Microchip 声明特定的使用假设（AoU）来满足系统级

的技术和功能安全要求。下文对 AoU 进行了介绍。其中一些 AoU 可参见本手册的其他章节，这些 AoU 作为所讨论特

定主题的一部分进行了介绍。最重要的使用假设是 MISRA 检查必须对照另一个同类型工具（例如，另一个独立

MISRA 检查）或另一种方法交叉进行以提高所展示结果的置信度。

表 3-1. 责任程度

必须 必须遵守

应 建议
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使用假设 说明

[AoU-01-MISRA] MISRA 检查必须对照另一个同类型工具或另一种方法交叉进行以提高所展示结果的置信度。

[AoU-02-MISRA] MISRA 检查只能与受支持的功能安全版 MPLAB XC 编译器配合使用。

[AoU-03-MISRA] MISRA 检查必须与真实功能安全流程配合使用。

[AoU-04-MISRA] MISRA 检查必须在 MPLAB X IDE 文档所规定的受支持平台上与适当版本的 MPLAB X IDE
（MPLAB X IDE v6.0 或更高版本）配合使用

[AoU-05-MISRA] MISRA 检查用户必须具备有效的许可证。

[AoU-06-MISRA] MISRA 检查只能用于受支持的 Microchip 单片机和 DSC。

[AoU-07-MISRA] 必须为所检查的规则和文件正确配置 MISRA 检查，以确保输出报告基于使用的接口。

[AoU-08-MISRA] MISRA 检查只能使用 MPLAB X IDE v6.0 或更高版本随附的 Cpp 检查工具。

3.3 执行 MISRA 检查

执行静态代码分析有助于识别源代码中的潜在问题或风险结构。

执行 MISRA 检查

按照下文所述执行静态代码分析。

• MISRA 检查主项目：单击工具栏图标 或从 Source（源代码）菜单中进行选择。

• MISRA 检查项目：在 Projects 窗口中，右键单击选择项目名称。

• MISRA 检查文件：在 Projects 窗口中，右键单击选择项目文件。

• 每次重新编译项目时运行 MISRA 检查：通过选择 Tools > Options > Embedded > MISRA Check > Run each
time project is rebuilt（工具 > 选项 > 已安装工具 > MISRA 检查 > 每次重新编译项目时运行）使能（作为编译的

一部分）。

静态代码分析输出
可通过以下方式之一输出静态代码分析的结果。

• Output 窗口：在“MISRA Check”选项卡下。

• HTML 报告文件：在 Tools > Options > Embedded > MISRA Check（工具 > 选项 > 已安装工具 > MISRA 检查）

中使能。

• CSV 报告文件：在 Tools > Options > Embedded > MISRA Check 中使能。

违规由“MISRA rule violated”（违反的 MISRA 规则）（规则编号和说明）与文件中的违规位置一起标识。

MISRA 规则设置

MISRA 规则设置位于 Tools > Options > Embedded > MISRA Check 中。

从命令行执行 MISRA 检查

misracli.bat（用于 Windows®）或 misracli.sh（用于 Linux®/Mac®）是用于 MISRA 规则检查的命令行应用程

序。请参见 3.5.  针对 MISRA 检查的命令行支持。

3.4 MISRA Check 选项卡

下面的 MISRA Check 选项卡支持按照相应标准检查应用程序代码。

要打开 MISRA Check 选项卡，请选择 Tools > Analysis > MISRA Check > MISRA Options（工具 > 分析 > MISRA 检

查 > MISRA 选项）。
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上图的表中列出了所有 MISRA C:2012 规则。灰显的规则需要手动选中。应用的规则可选择使能或禁止。

表 3-2. MISRA Check 选项

选项 说明

Run each time project is rebuilt
（每次重新编译项目时运行）

选中时可执行静态代码分析（作为编译的一部分）。

Allow rule suppression with code
comments（允许通过代码注释抑

制规则）

抑制已在代码中进行注释的规则。

Generate report files（生成报告

文件）

选中时可生成 HTML 或 CSV 格式的 MISRA 检查报告。报告带时间戳。HTML 或

CSV 报告会写入<project folder>\report。另外，还会在项目树中添加

“report”文件夹，以便能够查看文件。HTML 报告会列出以下信息：

• 执行检查的时间

• 违规——发现的问题

• 检查的内容

• 应用的规则

CVS 报告会列出以下信息：

• 违规——发现的问题

 
MISRA 检查

© 2022 Microchip Technology Inc.
及其子公司

 用户指南 DS50003236A_CN-第 24 页



...........（续）

选项 说明

Use custom Cppcheck path（使

用自定义 Cppcheck 路径）

提供自定义 Cppcheck 的链接来改写 MPLAB X IDE 捆绑的 Cppcheck。这用于扩

展/修改/更新应用的规则检查。

Additional Cppcheck arguments:
（其他 Cppcheck 参数：）

提供更多 Cppcheck 参数。

3.5 针对 MISRA 检查的命令行支持
针对 MISRA 检查的支持以命令行工具的形式提供。请参见[AoU-07-MISRA]。

安装

• 安装最新 MPLAB X IDE。
• 打开本机命令提示符（Windows、Linux 和 Mac），导航到 MPLAB X IDE 安装目录的 bin 文件夹。例如，在

Windows 操作系统上：C:\Program Files\Microchip\MPLABX\v6.0\mplab_platform\bin。
• Misra 检查命令行实用程序为 misracli.bat（Windows）或 misracli.sh（Linux/Mac）。

示例

以下示例使用 Windows 版本（Linux/Mac 版本使用 misracli.sh代替 misracli.bat）。

正常使用：

默认情况下，MISRA 检查命令行接口将使能所有规则，但可使用–disable选项禁止特定规则。

要获取所有可用 MISRA 检查命令行接口选项的完整列表，请运行：

C:\Program
        Files\Microchip\MPLABX\[vX.XX]\mplab_platform\bin\misracli.bat
        –help

• misracli.bat myFile.c在单个文件上运行 MISRA 检查并在输出中报告错误。

• misracli.bat myDirectory在给定目录下的所有.c、.cpp、.cxx、.cc、.h、.hpp、.hxx和.hh文件上

递归运行 MISRA 检查。

• 如果未发现错误，misracli.bat返回 0；如果检测到错误，则返回非 0 值。

特殊选项

• misracli.bat --help列出所有选项及说明。

• misracli.bat --version显示版本号。

• 添加选项--quiet仅显示警告和错误（示例：源文件缺失或--cppcheck param使用不当）。

• 添加选项--silent将禁止所有输出（但返回值应正确且可与报告一起使用）。

• 使用选项--workdir=myDirectory将在非当前工作目录的另一个文件夹中运行分析。

• 使用选项--cppcheck="C:\Program Files\myCustomCppCheckInstallation\cppcheck.exe”将运

行用户安装的 cppcheck.exe（从 cppcheck.sourceforge.io/获取）。

报告：

• 添加选项--html=myReport.html将生成 html 报告。

• 添加选项--csv=myReport.csv将生成 csv 报告。

规则处理：

• 添加选项--disable="1.2 1.3"将在禁止检查规则 1.2 和 1.3 的情况下检查文件。

• 添加选项--nosuppression将禁止会抑制规则的内嵌代码注释。
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4. 版本历史

4.1 版本 A（2021 年 12 月）
本文档的初始版本。
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Microchip 网站

Microchip 网站（www.microchip.com）为客户提供在线支持。客户可通过该网站方便地获取文件和信息。我们的网站

提供以下内容：

• 产品支持——数据手册和勘误表、应用笔记和示例程序、设计资源、用户指南以及硬件支持文档、最新的软件版
本以及归档软件

• 一般技术支持——常见问题解答（FAQ）、技术支持请求、在线讨论组以及 Microchip 设计伙伴计划成员名单

• Microchip 业务——产品选型和订购指南、最新 Microchip 新闻稿、研讨会和活动安排表、Microchip 销售办事

处、代理商以及工厂代表列表

产品变更通知服务

Microchip 的产品变更通知服务有助于客户了解 Microchip 产品的最新信息。注册客户可在他们感兴趣的某个产品系列

或开发工具发生变更、更新、发布新版本或勘误表时，收到电子邮件通知。

欲注册，请访问 www.microchip.com/pcn，然后按照注册说明进行操作。

客户支持

Microchip 产品的用户可通过以下渠道获得帮助：

• 代理商或代表

• 当地销售办事处

• 应用工程师（ESE）
• 技术支持

客户应联系其代理商、代表或 ESE 寻求支持。当地销售办事处也可为客户提供帮助。本文档后附有销售办事处的联系

方式。

也可通过 www.microchip.com/support 获得网上技术支持。

Microchip 器件代码保护功能

请注意以下有关 Microchip 产品代码保护功能的要点：

• Microchip 的产品均达到 Microchip 数据手册中所述的技术规范。

• Microchip 确信：在正常使用且符合工作规范的情况下，Microchip 系列产品非常安全。

• Microchip 注重并积极保护其知识产权。严禁任何试图破坏 Microchip 产品代码保护功能的行为，这种行为可能会

违反《数字千年版权法案》（Digital Millennium Copyright Act）。

• Microchip 或任何其他半导体厂商均无法保证其代码的安全性。代码保护并不意味着我们保证产品是“牢不可破”

的。代码保护功能处于持续发展中。Microchip 承诺将不断改进产品的代码保护功能。

法律声明

提供本文档的中文版本仅为了便于理解。请勿忽视文档中包含的英文部分，因为其中提供了有关 Microchip 产品性能和

使用情况的有用信息。Microchip Technology Inc.及其分公司和相关公司、各级主管与员工及事务代理机构对译文中可

能存在的任何差错不承担任何责任。建议参考 Microchip Technology Inc.的英文原版文档。

本出版物及其提供的信息仅适用于 Microchip 产品，包括设计、测试以及将 Microchip 产品集成到您的应用中。以其他

任何方式使用这些信息都将被视为违反条款。本出版物中的器件应用信息仅为您提供便利，将来可能会发生更新。如

需额外的支持，请联系当地的 Microchip 销售办事处，或访问 https://www.microchip.com/en-us/support/design-help/
client-supportservices。
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Microchip“按原样”提供这些信息。Microchip 对这些信息不作任何明示或暗示、书面或口头、法定或其他形式的声明

或担保，包括但不限于针对非侵权性、适销性和特定用途的适用性的暗示担保，或针对其使用情况、质量或性能的担

保。

在任何情况下，对于因这些信息或使用这些信息而产生的任何间接的、特殊的、惩罚性的、偶然的或间接的损失、损

害或任何类型的开销，Microchip 概不承担任何责任，即使 Microchip 已被告知可能发生损害或损害可以预见。在法律

允许的最大范围内，对于因这些信息或使用这些信息而产生的所有索赔，Microchip 在任何情况下所承担的全部责任均

不超出您为获得这些信息向 Microchip 直接支付的金额（如有）。如果将 Microchip 器件用于生命维持和/或生命安全应

用，一切风险由买方自负。买方同意在由此引发任何一切损害、索赔、诉讼或费用时，会维护和保障 Microchip 免于承

担法律责任。除非另外声明，在 Microchip 知识产权保护下，不得暗中或以其他方式转让任何许可证。

商标

Microchip 的名称和徽标组合、Microchip 徽标、Adaptec、AVR、AVR 徽标、AVR Freaks、BesTime、BitCloud、
CryptoMemory、CryptoRF、dsPIC、flexPWR、HELDO、IGLOO、JukeBlox、KeeLoq、Kleer、LANCheck、
LinkMD、maXStylus、maXTouch、MediaLB、megaAVR、Microsemi、Microsemi 徽标、MOST、MOST 徽标、

MPLAB、OptoLyzer、PIC、picoPower、PICSTART、PIC32 徽标、PolarFire、Prochip Designer、QTouch、SAM-
BA、SenGenuity、SpyNIC、SST、SST 徽标、SuperFlash、Symmetricom、SyncServer、Tachyon、TimeSource、
tinyAVR、UNI/O、Vectron 及 XMEGA 均为 Microchip Technology Incorporated 在美国和其他国家或地区的注册商

标。

AgileSwitch、APT、ClockWorks、The Embedded Control Solutions Company、EtherSynch、Flashtec、Hyper
Speed Control、HyperLight Load、Libero、motorBench、mTouch、Powermite 3、Precision Edge、ProASIC、

ProASIC Plus、ProASIC Plus 徽标、Quiet-Wire、SmartFusion、SyncWorld、Temux、TimeCesium、TimeHub、
TimePictra、TimeProvider、TrueTime 和 ZL 均为 Microchip Technology Incorporated 在美国的注册商标。

Adjacent Key Suppression、AKS、Analog-for-the-Digital Age、Any Capacitor、AnyIn、AnyOut、Augmented
Switching、BlueSky、BodyCom、Clockstudio、CodeGuard、CryptoAuthentication、CryptoAutomotive、
CryptoCompanion、CryptoController、dsPICDEM、dsPICDEM.net、Dynamic Average Matching、DAM、ECAN、

Espresso T1S、EtherGREEN、GridTime、IdealBridge、In-Circuit Serial Programming、ICSP、INICnet、Intelligent
Paralleling、IntelliMOS、Inter-Chip Connectivity、JitterBlocker、Knob-on-Display、KoD、maxCrypto、maxView、

memBrain、Mindi、MiWi、MPASM、MPF、MPLAB Certified 徽标、MPLIB、MPLINK、MultiTRAK、NetDetach、
Omniscient Code Generation、PICDEM、PICDEM.net、PICkit、PICtail、PowerSmart、PureSilicon、QMatrix、
REAL ICE、Ripple Blocker、RTAX、RTG4、SAM-ICE、Serial Quad I/O、simpleMAP、SimpliPHY、SmartBuffer、
SmartHLS、SMART-I.S.、storClad、SQI、SuperSwitcher、SuperSwitcher II、Switchtec、SynchroPHY、Total
Endurance、Trusted Time、TSHARC、USBCheck、VariSense、VectorBlox、VeriPHY、ViewSpan、WiperLock、
XpressConnect 和 ZENA 均为 Microchip Technology Incorporated 在美国和其他国家或地区的商标。

SQTP 为 Microchip Technology Incorporated 在美国的服务标记。

Adaptec 徽标、Frequency on Demand、Silicon Storage Technology 和 Symmcom 均为 Microchip Technology Inc.在
除美国外的国家或地区的注册商标。

GestIC 为 Microchip Technology Inc.的子公司 Microchip Technology Germany II GmbH & Co. KG 在除美国外的国家

或地区的注册商标。

在此提及的所有其他商标均为各持有公司所有。

© 2022, Microchip Technology Incorporated 及其子公司版权所有。

ISBN： 978-1-6683-0465-5

质量管理体系

有关 Microchip 的质量管理体系的信息，请访问 www.microchip.com/quality。
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2355 West Chandler Blvd.
Chandler, AZ 85224-6199
电话：480-792-7200
传真：480-792-7277
技术支持：

www.microchip.com/support
网址：

www.microchip.com
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电话：86-27-5980-5300
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电话：86-29-8833-7252
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电话：86-592-2388138
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电话：91-11-4160-8631
印度 - 浦那

电话：91-20-4121-0141
日本 - 大阪

电话：81-6-6152-7160
日本 - 东京
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